python2.7中pip报错

最近一个项目用到python2,其中使用到了pip这个工具,无奈发现报错,就连pip -V都可以报错,也就是下面的这个报错:

1># pip -V
Traceback (most recent call last):                                                                                                                                   
  File "/usr/bin/pip", line 7, in <module>                                                                                                                           
    from pip._internal import main                                                                                                                                   
ImportError: No module named _internal

报错

于是乎在网上查询了解决办法,恩..清一色的一个答案 复制过来复制过去的,然而对于我的问题丝毫没有得到解决,不过大多数都提到了一个网站:https://bootstrap.pypa.io/
,于是我就访问了这个网站看了一下:

目录,不同版本的都有

而网络上大致都是直接:wget https://bootstrap.pypa.io/get-pip.py
可能会报错,可能默认的就是3.x版本的,不要尝试从上面的版本里面进行拉取,进入到pip文件夹,这里面有相对应的版本,获取到相对应的版本就好了,服务器本身的版本是2.7的,所以我这样执行:

wget https://bootstrap.pypa.io/pip/2.7/get-pip.py

python get-pip.py

安装成功 pip -V 查看无报错

就可以完美的安装上去了,大致就这样,记录一下

本博客所有文章如无特别注明均为原创。作者:止语复制或转载请以超链接形式注明转自 止语-编程学习分享
原文地址《python2.7中pip报错

相关推荐

发表评论

路人甲
看不清楚?点图切换

网友评论(0)